Introduction

This manual is to serve as guidance to Contractors to help expedite creating, updating, submitting, reviewing, and approving schedules. This manual is not intended to replace the Item 639 CPM Scheduling Specification, but rather provide further guidance and best practices. In 2015, the NYSDOT CPM Scheduling Section uploaded and reviewed over 900 individual schedule submissions for 95 different projects. This manual helps summarize many of the lessons learned, and provides solutions to common problems and frequently asked questions, as well as tips to help Contractors adhere to the NYSDOT CPM Scheduling Specification. This manual is considered guidance and not official policy.
Contents

Chapter 1. Building the Schedule ............................................................... 4
  1. Schedule Work Flow .............................................................................. 4
  2. Accessing Primavera P6 through Citrix .................................................. 4
  3. P6 EPS Structure ................................................................................... 5
  4. Creating a New File in P6 ...................................................................... 6
     4.1. Copy / Pasting a New File in Contractor’s Work Area ...................... 6
     4.2. Changing Project ID and Project Name ............................................ 7
  5. WBS Development ................................................................................ 8
     5.1. Carry Down Higher Levels of WBS to Lower Levels ......................... 8
     5.2. Recommended WBS Organization .................................................. 8
  6. Bulk Upload of Activities and Activity Relationships ......................... 9
  7. Activity Names ..................................................................................... 12
     7.1. Standard Naming Convention ......................................................... 12
     7.2. Consistent Activity Names ............................................................ 12
     7.3. Copy / Pasting WBS Name to end of Activity Name ...................... 12
     7.4. Minimizing the Length of Activity Names ....................................... 13
  8. Calendars ............................................................................................. 13
     8.1. Global Calendars ............................................................................. 13
     8.2. Project Calendars – Standard 5d 8h Calendars ................................ 14
     8.3. Assigning Seasonal Activities to Appropriate Calendars .............. 14
     8.4. Winter Shutdown Calendar ............................................................ 16
     8.5. Creating Calendars with Workweek other than 5d 8h .................... 16
     8.6. Accounting for Weather Days ....................................................... 18
     8.7. Pushing out the Start of Future Work with Calendars rather than Constraints .............. 18
     8.8. Overtime / Dispensation in Baseline .............................................. 19
  9. Populating Activity Codes and Calendars ........................................... 19
     9.1. View all Available Activity Codes and Calendars .......................... 19
     9.2. Layout to Input Activity Codes and Calendars ............................... 19
     9.3. Populate Many Activities at Once – Fill Down Shortcut ................ 21
  10. Schedule Checks Using Excel ............................................................. 23
     10.1. Spell Check .................................................................................. 23
     10.2. Duplicate Activity Names ............................................................... 26
  11. Time Restricted Clauses .................................................................... 28
     11.1. Contract Completion Date ............................................................... 28
     11.2. Interim Contract Milestones ......................................................... 28
     11.3. Liquidated Damage (LD) and Incentive / Disincentive (I/D) Duration Periods ........... 28
  12. Sequencing Activities ....................................................................... 29
Chapter 2. Checking the Schedule

1. Immediate Rejection Criteria and Tips for Correcting Deficiencies
2. Reviewing the Schedule Log and Correcting Errors
   2.1. Creating the Schedule Log
   2.2. Schedule Logs Must Match
   2.3. Schedule Log Errors and Tips for Correcting Errors
3. Using Global Filters to Check Schedules
   3.1. Description of Global Filters and How to Apply Filters
   3.2. List of Global Filters and Tips for Correcting Potential Deficiencies
4. Multiple Float Paths
   4.1. How to Calculate Multiple Float Paths
   4.2. Layout for Reviewing Multiple Float Paths
5. Opening ‘Schedule Report’ Global Layouts
6. Notebook Utilization
   6.1. Making Notes on Activities
   6.2. Printing Notebook Topic Report

Chapter 3. Submitting the Schedule

1. Submission Work Flow
2. Schedule Submission Due Dates
3. File Naming Conventions
4. Narrative
5. Exporting / Copying / Saving
   5.1. T-drive
   5.2. File Transfer of PDF Files
   5.3. Exporting Schedule File
   5.4. Schedule Log
   5.5. Claim Digger
6. Email Submission Protocol
7. Schedule Submission Checklist

Chapter 4. Attachments

Attachment 1 - NYSDOT Schedule Work Flow
Attachment 2 – NYSDOT Schedule Submission Checklist
Chapter 1. Building the Schedule

This Chapter provides an overview of the CPM schedule submission requirements, structure of the NYSDOT P6 system, and guidance and tips to help create a submission that meets the NYSDOT CPM scheduling specification standard.

1. Schedule Work Flow

Attachment 1 – Schedule Work Flow separates the steps of the Item 639 CPM scheduling process in sequential order. The work flow diagrams the process for the Contractor, CPM Scheduling Section, EIC, ACS and the optional Detailed Reviewers, from Letting Date through Contract Completion and the As-Built Schedule. The phases include:

   Project Setup ➔ Baseline Schedule Development ➔ Monthly Updates ➔ As-Built Schedule

It is strongly recommended that this process be reviewed to understand which party has responsibilities during each of the above phases of the CPM schedule.

2. Accessing Primavera P6 through Citrix

The scheduling software, Primavera P6, is hosted through the NYSDOT Citrix website, https://citrix.dot.ny.gov/. Upon completing the access request form (as shown in the Schedule Flow Chart), the scheduler will be granted access to the NYSDOT Citrix website. Once logging into Citrix, the user has access to various Citrix XenApp Server Applications. One of these applications is Primavera P6:

Click on the Primavera icon to open the application, and log into P6 using the same user name and password used to log into Citrix.

Note: If the user experiences issues logging into Citrix and/or P6, please contact the NYSDOT HelpDesk (518-485-8111). Scheduling Software, User Access, and User Security Privileges are discussed in detail in the scheduling specification.

Note: Repeat users are no longer required to have Request for Access forms notarized. New access for Contractors and Consultants still need to be notarized.
3. P6 EPS Structure

In P6, the Enterprise Project Structure (EPS) is set up and maintained by the CPM Scheduling Section to provide separate nodes – P6 schedule file folders – specific to the Contractor's schedule, archived Read Only schedule copies, and NYSDOT What-If schedules. Each of the various nodes have different security roles assigned, which based on the user, allows the user rights to view or not view, and read and/or write to the specific files within that node. Below is a table summarizing the various nodes, the users who have access each to these nodes, and the capabilities of each user within each node. Administrators in the CPM Scheduling Section have access to read/write to all schedule files within this system.

### P6 EPS Structure Example

<table>
<thead>
<tr>
<th>Node</th>
<th>Description</th>
<th>CPM Scheduling Section Admin</th>
<th>Pre-Letting Design Schedulers</th>
<th>Contractor Project Scheduler</th>
<th>Regional NYSDOT / Schedule Reviewer</th>
</tr>
</thead>
<tbody>
<tr>
<td>DWA</td>
<td>Designer's Work Area: Seldom used node for development of pre-letting schedules.</td>
<td>Read &amp; Write</td>
<td>Read &amp; Write</td>
<td>No View</td>
<td>Read Only</td>
</tr>
<tr>
<td>CWA</td>
<td>Contractor's Work Area: Contractor's node to prepare schedule submissions and create their own What-If files.</td>
<td>Read &amp; Write</td>
<td>No View</td>
<td>Read &amp; Write</td>
<td>No View</td>
</tr>
<tr>
<td>FBS</td>
<td>Final Baseline Progress Schedule @ Award: Archived copy of the accepted Baseline schedule.</td>
<td>Read &amp; Write</td>
<td>No View</td>
<td>Read Only</td>
<td>Read Only</td>
</tr>
<tr>
<td>CPS</td>
<td>Current Progress Schedule: Archived copy of the most recently submitted schedule.</td>
<td>Read &amp; Write</td>
<td>No View</td>
<td>Read Only</td>
<td>Read Only</td>
</tr>
<tr>
<td>PPS</td>
<td>Past Progress Schedules: Archived copies of previously submitted schedules.</td>
<td>Read &amp; Write</td>
<td>No View</td>
<td>Read Only</td>
<td>Read Only</td>
</tr>
<tr>
<td>ABPS</td>
<td>As-Built Progress Schedule: Archived copy of the As-Built schedule.</td>
<td>Read &amp; Write</td>
<td>No View</td>
<td>Read Only</td>
<td>Read Only</td>
</tr>
<tr>
<td>WI</td>
<td>What-If Schedules: NYSDOT's node to modify copies of the schedule submission and run What-If scenarios.</td>
<td>Read &amp; Write</td>
<td>No View</td>
<td>No View</td>
<td>Read &amp; Write</td>
</tr>
</tbody>
</table>
4. Creating a New File in P6

Within the P6 EPS in the Contractor’s Work Area node, the Contractor has rights to add, copy and paste new P6 files. Below discusses how to copy/paste files within the Contractor’s Work Area, as well as how to change the Project ID and Project Name to the most current submission.

NOTE: To help avoid accidental deletions of files, the Contractor is unable to delete P6 files within the Contractor’s Work Area. Should the Contractor want files deleted, this can be performed by the CPM Scheduling Section. The Contractor should put “DELETE” in both the Project ID and Project Name and send an email to the CPM Scheduling Section identifying the specific Project ID to be deleted. Users are encouraged to do so, as less files and a smaller database will speed up software performance. The Contractor will maintain the ability to view and copy any previous submissions from the read-only nodes, if necessary.

4.1. Copy / Pasting a New File in Contractor’s Work Area

To create a new submission – whether it is a revision to a Baseline or a new monthly update – the Contractor will need to make a new copy of the schedule file within the Contractor’s Work Area. To make a copy of the schedule:

- **Step 1** – In the Projects view in the Contractor’s Work Area node, right-click on a schedule file, select **Copy**.

- **Step 2** – In the Projects view, right-click on the Contractor’s Work Area node, select **Paste**.
4.2. Changing Project ID and Project Name

Once a new file is created, the Project ID and Project Name need to be modified to reflect the nomenclature of the current submission. There are two ways to rename the Project ID and Project Name.

- **Option 1** – In the *Projects* view in the *Contractor's Work Area* node, double left-click on the Project ID or Project Name for the file you want renamed. This will allow these fields to be edited.

- **Option 2** – Another option is in the WBS view, which also allows the user to edit the Project ID and Project Name.
  
  - **Step 1** – Right-click on the Project and select *Open Project*.
  
  - **Step 2** – In the Menu bar, click on Project > WBS.
  
  - **Step 3** – At the top level of the WBS, double left-click on the WBS Code and WBS Name to edit the Project ID and Project Name, respectively.
5. **WBS Development**

5.1. **Carry Down Higher Levels of WBS to Lower Levels**

During the WBS development, each node of the WBS should be unique, identifiable, and a further detailed breakdown of the respective higher level hierarchical WBS node. In the below example, nomenclature from the higher levels of the WBS are carried down to the lower levels to best communicate the scope of work within each respective WBS node.

5.2. **Recommended WBS Organization**

It is recommended that the WBS be organized by location and then Stage / Phase. Activity Codes can be assigned to each activity for respective Stage / Phase to provide flexibility and other options for grouping / viewing activities. In the below example for reconstruction of elevated roadway and two bridges, the locations are the higher level of the WBS and stages are below each location. An Activity Code for Stage 1 and Stage 2 can be assigned to all activities to provide flexibility to view / filter the schedule for each respective Stage.
6. Bulk Upload of Activities and Activity Relationships

Contractors have the ability to bulk upload Activities and Activity Relationships into P6 using the “Bulk Upload Activities” tool.

The following data can be imported for Activities in the Activities tab.

- Activity ID
- Activity Name
- Duration (Working Days)
- Activity Type (Task Dependent, Resource Dependent, Level of Effort, Start Milestone, Finish Milestone or WBS Summary)

The following data can be imported for Activity Relationships in the Relationships tab.

- Predecessor (Predecessor Activity ID)
- Successor (Successor Activity ID)
- Relationship Type (FS, FF, SS or SF)
- Lag (Days)

Below are the steps to use the Bulk Upload tool.

- **Step 1** – Confirm that the schedule has the default “CONSTRUCTION” WBS node provided in the schedule template – this is where all activities will be imported.
- **Step 2** – Open the tool under Tools > Bulk Upload > Activities. A new window will open with a table for the bulk upload template showing Activities, Relationships and Log tabs.

NOTE: Please become familiar with the rules on the template. Also, be sure the column headings are ordered correctly from your source document and this template, for both the Activities and Activities Relationships.
Best Practices for CPM Schedule Specification Compliance

Step 3 – There are two options to populate the Bulk Upload Template:

- Copy/paste from an Excel spreadsheet using “Ctrl + V” to Paste.
- Enter the information manually using the template provided.

NOTE: If using a different schedule system than P6, first export schedule data to an Excel spreadsheet and be sure the column order and values match the Bulk Upload Template. Information from Microsoft Project, for example, may not have the same field names. The table below shows an example cross-reference to P6 terms.

<table>
<thead>
<tr>
<th>Bulk Upload Activity Template</th>
<th>P6 Activity Equivalent</th>
<th>Bulk Upload Activity Relationships Template</th>
<th>P6 Activity Relationship Equivalent</th>
</tr>
</thead>
<tbody>
<tr>
<td>ID</td>
<td>Activity ID</td>
<td>Predecessor</td>
<td>Predecessor</td>
</tr>
<tr>
<td>Name</td>
<td>Activity Name</td>
<td>Successor</td>
<td>Successor</td>
</tr>
<tr>
<td>Durations (Days)</td>
<td>Original Duration (d)</td>
<td>Relationship Type</td>
<td>Relationship Type</td>
</tr>
<tr>
<td>Act Type</td>
<td>Activity Type</td>
<td>Lag (Days)</td>
<td>Lag (d)</td>
</tr>
</tbody>
</table>

If using an Excel Export from scheduling software, verify that columns are correct for both the Activities and Activities Relationships under the Subject Area, which may resemble the images below taken from a P6 Export option.
• **Step 4** – Enter or Upload. **User MUST always upload Activity information first** – Activities must exist before relationships can be established between the Activities in the Activity Relationship tab. Select and Copy columns; and Paste into the template using “Ctrl + V”.  
  
  TIP: When entering data into a cell, user must hit Enter or click in an empty cell to save the information in the Bulk Upload Template for the system to recognize, validate and upload the data.  
  
• **Step 5** – Select **Validate** once Activity information is entered. The log tab will identify any errors. If “Construction WBS does not exist” error appears, please contact the CPM Scheduling Section at CPMSchedulingSection@dot.ny.gov.  
  
• **Step 6** – Return to the Activities tab and select **Activities Upload**.  
  
  **Tip:** It is recommended to import groups of activities within specific WBS elements and then move these activities to the appropriate WBS nodes within P6, rather than importing all activities at once. Once all groups of activities are imported and moved to the proper WBS nodes, then import Activity Relationships.  
  
• **Step 7** – Once successfully loaded, user may begin loading data in the **Relationships** tab. Enter the information as described above, or **Copy and Paste** the columns matching the **Relationships** data.  
  
• **Step 8** – Select **Validate** once Activity information is entered and return to the **Relationships** tab and select **Upload**. The **Log** tab will identify any errors.  
  
• **Step 9** – Refresh (F5) the project in P6 and verify the newly added activities and activity relationships are present in the “CONSTRUCTION” WBS node.  
  
• **Step 10** – Cut/paste activities from the “CONSTRUCTION” node to the appropriate WBS node.
7. **Activity Names**

7.1. **Standard Naming Convention**

Organized, structured Activity Names provide the most flexibility for filtering, grouping, sorting, and reviewing the schedule. The specification requires that all Activity names be unique and include a verb, object and location. It is recommended that each Activity Name be defined in that order:

\[ \text{[Verb]} \text{ [Object]} – \text{[Specific Location]} \]

For example:

*Place Concrete – E Abut – S1 Rt. 66*

When all grouping is removed and activities are sorted by Activity Name, this makes it easy to see all “Place Concrete” activities in succession and apply the appropriate Activity Codes and Calendars at once.

7.2. **Consistent Activity Names**

Similar activities should share the same naming convention and be consistent throughout the schedule. This allows for the most effective schedule for viewing, sorting and filtering. For example, choose one of each of following and remain consistent throughout the schedule. WBS Names may be more descriptive than the abbreviated Activity Names.

- “FRP” vs. “F-R-P” vs. “Form Rebar Pour” vs. “Form, Rebar, Pour”
- “S1” vs. “Stg 1” vs. “Stage 1”

7.3. **Copy / Pasting WBS Name to end of Activity Name**

A shortcut to adding the location to the end of each activity name is to copy/paste an abbreviated version of the WBS Name to the end of the Activity Names within that WBS. For example, the following activities were added as part of an abutment construction:

<table>
<thead>
<tr>
<th>Activity D</th>
<th>Activity Name</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td><strong>Rt. 66 Bridge Reconstruction</strong></td>
</tr>
<tr>
<td></td>
<td>North Half - Stage 1 - Rt. 66 Bridge Reconstruction</td>
</tr>
<tr>
<td></td>
<td>Substructure - Stage 1 Rt. 66</td>
</tr>
<tr>
<td></td>
<td><strong>East Abutment - Stage 1 Rt. 66</strong></td>
</tr>
<tr>
<td>C9020</td>
<td>Structural Excavation</td>
</tr>
<tr>
<td>C9025</td>
<td>Install Piles</td>
</tr>
<tr>
<td>C9030</td>
<td>Install Forms &amp; Rebar</td>
</tr>
<tr>
<td>C9035</td>
<td>Place Concrete</td>
</tr>
<tr>
<td>C9040</td>
<td>Cure Concrete</td>
</tr>
</tbody>
</table>

On a multiple bridge schedule where there may be similar activities at several abutments, this group of activities can be copy/pasted into the several separate, similar WBS nodes. Once all copies of the activities are made, the Contractor can add the specific location to the end of each Activity Name to make each Activity Name unique. In this example, an abbreviated version of the WBS node is created and copy/pasted to the end of each Activity Name within this WBS node.

“East Abutment – Stage 1 Rt. 66” → “E Abut – S1 Rt. 66”
7.4. Minimizing the Length of Activity Names

While the above requirement to have a verb, object and location in each Activity Name may result in longer Activity Names (for example, “Place Concrete – East Abut – Stage 1” versus “Concrete”), there are some recommendations to minimizing the length of Activity Names to help maximize space in printouts for other columns of information.

- Avoid using all capital letters, which results in wider Activity Names and less space for other information. Additionally, Spell Check in Excel does not work as well with all capital letters.

- Abbreviate where appropriate, but not to a point where it is not intuitive to someone who has not built the schedule.

8. Calendars

8.1. Global Calendars

The Contractor has the ability to view and assign many Global Calendars to activities. However, only two Global Calendars are allowed to be used because only these two are regularly maintained to ensure their accuracy. These two calendars are:

- **State Business Days, 5 Day Work Week w/ State Holidays, Field**
  
  This calendar is 5 days per week, 8 hours per day, and has all standard NYSDOT holidays included. This is to be assigned to all non-milestone, State-responsible activities. Other activities under the responsibility of third party agencies should also potentially be assigned to this calendar (e.g., railroads, State permitting, utility companies), unless third party agencies are working on a specific defined calendar.
• **NYSDOT Milestone/Curing 365 Day / 8 Hour**
  This calendar is 365 days (no non-work days), 8 hours per day, and is to be assigned to all:
  - Concrete curing activities
  - Milestone activities
  - Level of Effort activities

8.2. **Project Calendars – Standard 5d 8h Calendars**

The Contractor is required to assign all Contractor-responsible activities to Project Calendars, with the exception of those activities required to be assigned to the **NYSDOT Milestone/Curing 365 Day / 8 Hour** calendar noted above.

In the template schedule provided to Contractors, the default calendar is a standard 5-day, 8-hour Project Calendar that includes all NYSDOT holidays. This calendar can be assigned to all activities that will be worked on a standard 5-day, 8-hour schedule and can be performed year-round. Examples include but are not limited to submittals, fabrication, and construction activities that can be performed year-round, regardless of weather.

8.3. **Assigning Seasonal Activities to Appropriate Calendars**

Most projects have activities that cannot be performed year-round and these activities shall be assigned to specific calendars that reflect any restrictions as non-work periods. Examples include but are not limited to planned winter shutdown periods, asphalt paving, deck and other concrete placement, stream work, landscaping, and clearing and grubbing. To create separate restriction calendars:

- **Step 1** – Access the Calendars by clicking **Enterprise > Calendars**.

- **Step 2** – In the Calendars window, click the button for **Project**. Click Add+. A window will pop up asking to **Select Calendar to Copy From**, which provides choices of Global Calendars. Use the calendar **State Business Days, 5 Day Work Week w/State Holidays, Field** – this will ensure that your new calendar has a base template that already includes all NYSDOT holidays. Click the green (+) icon.
• **Step 3** – The default name for the new calendar will be *(New Calendar)*. Rename this new calendar with the D# and a short description. For example, **D269997 – Asphalt Paving**.

• **Step 4** – Highlighted on this new calendar, in the **Calendars** window, click **Modify**, which will open up a window to modify work and non-work days.

• **Step 5** – Scroll through the months to restricted periods for this specific calendar and mark restricted days as non-work days. Multiple days can be selected at once by clicking the weekday header (Mon, Tue, Wed, etc.) and the click **Nonwork**. This will “gray out” these days as non-work days. The non-work periods should be detailed in the Contractor’s Narrative.

  Continue to mark all seasonally restricted days as “Nonwork” days, from the start of the project through one year beyond the Contract Completion Date. This will ensure that if activities slip beyond the Contract Completion Date, seasonal restrictions will still be applied to activities.
Step 6 – In the Activity view, reassign any activities affected by this restriction to the specific calendar. This will prevent these activities from being scheduled during these non-work times.

8.4. Winter Shutdown Calendar

The above process for seasonal calendar restrictions is common for Contractors to create a standard calendar that includes a winter shutdown period. Winter shutdown periods must be represented in seasonal calendars and cannot be represented in the schedule by a “Winter Shutdown” activity. The Contractor should use the steps above to create a calendar that represents their plan for a winter shutdown. If some construction operations will continue year-round and others will be on hold for a winter shutdown, these separate activities can be assigned to separate calendars.

If a “Winter Shutdown” activity is used instead of an appropriate seasonally-restricted calendar, very frequently as the schedule is updated, the Winter Shutdown activity shifts earlier and later, inappropriately representing the winter shutdown period and falsely moving work in the next season in and out. For example, if Season 1 work is delayed by one month and the November through March planned shutdown activity is now pushed to December through April, the schedule will show work will not starting in Season 2 until May, and potentially pushing the end of Season 2 and project completion beyond a contract date. In reality, Season 2 work will most likely not be affected by a slightly late completion of Season 1 work.

8.5. Creating Calendars with Workweek other than 5d 8h

When creating calendars with a workweek that is different than the standard 5-day, 8-hour, there are additional steps to ensure the schedule is calculated and presented properly. Examples include 6-day schedules, weekend schedules, and/or 10-hour days.

- **Steps 1-4** – Follow Steps 1-4 above for Assigning Seasonal Activities to Appropriate Calendars.
Best Practices for CPM Schedule Specification Compliance

- **Step 5** – To modify the standard work days within a work week, after clicking **Modify**, click the button for **Detailed work hours/day**, and click **Workweek**.

- **Step 6** – Under **Day of the Week**, click on the day to change the Work / Nonwork times. Modify the hours within that day to represent the planned work hours. In the below example, Saturday is modified to work 8 hours, similar to Monday through Friday. Click the **Work** button to make Saturday a standard work day for this calendar. Click **OK** to exit this window.

- **Step 7** – Click **Time Periods** to open the **Hours per Time Period** window. Modify the **Hours/Day** and **Hours/Week** to represent any changes made above. In the above example, **Hours/Week** is changed from 40 to 48 to reflect adding Saturday at an 8-hour work day.

  If a 5-day, 10-hour calendar was created, **Hours/Day** would be changed to “10” and **Hours/Week** would be changed to “50”.
8.6. Accounting for Weather Days

It is recommended that weather days should be included in the Contractor’s production rates when populating activity Original Durations and should not be blocked out as sporadic non-work days throughout calendars. Blocking out sporadic non-work days for weather creates multiple issues:

- Producing short-term look-ahead schedules will not allow work to be scheduled on the blocked out days. If formwork and rebar are complete on Thursday, it will not be clear why the successive concrete placement is pushed out to the next Monday, rather than Friday.
- If work is performed during these sporadic non-work days, then the Actual Duration for each activity is incorrect because these days are shown as non-working time.
- Sporadic non-work days do not represent the actual weather days. If a calendar is accounting for weather, it should be accurate. Calendars cannot be changed without prior approval, so a separate “as-built” weather calendar would need to be created and then all completed activities moved to this calendar. This creates many opportunities for errors, as an activity should generally have the same calendar throughout the life of a project.

8.7. Pushing out the Start of Future Work with Calendars rather than Constraints

If there is work planned to start at the beginning of a construction season other than the first season of the project, and the Contractor will not start this work earlier than the planned winter shutdown, it is recommended that a separate calendar is created to push out this work to the successive season. An example is a project with a two-stage bridge replacement where Stage 1 is planned for Year 1 and Stage 2 is planned for Year 2. Even if Stage 1 completes early in Year 1, the Contractor will not start Stage 2 until Year 2.

- **Step 1** – Create separate calendar identifying what work is being pushed out, and to when (i.e., “D269997 – Start Stage 2 in April 2018”).
- **Step 2** – Block out all days prior to the planned start date as non-working days.
- **Step 3** – Assign all appropriate Stage 2 activities to this calendar.
- **Step 4** – Identify in the Narrative why this calendar was created and note the planned start date for work in the successive season.

A solution that does not meet specification for this circumstance is for the Contractor to put a Constraint on the first activity of Year 2 to “Start On or After” the planned date in Year 2. This will hold the start of Stage 2 out to Year 2 the same as the recommendation above; however when viewing the Longest Path, Stage 1 and Year 1 activities will not show up on the Longest Path – only Stage 2, Year 2 activities artificially held out by the Constraint will show up on the Longest Path.
8.8. Overtime / Dispensation in Baseline

Most NYSDOT contracts do not allow for work hours beyond the standard 5-day, 8-hour workweek. In the event that additional days of the workweek and or additional hours are approved in the contract documents, the Contractor may create and assign calendars that represent extended workweeks. In the event that dispensation is not approved in the contract and it is apparent that dispensation for overtime will be approved for specific critical work, with prior approval from the EIC it is acceptable for the Contractor to show extended workweeks in the Baseline. However, should dispensation not be approved, the Contractor will be responsible for producing a schedule that shows how work will be completed by the contract dates while working a standard 5-day, 8-hour workweek.

9. Populating Activity Codes and Calendars

9.1. View all Available Activity Codes and Calendars

By default when opening P6, often the user can only view Activity Codes and Calendars currently assigned to the open Project. This may make it appear that the Contractor only has access to a limited number of Activity Codes and Calendars. To ensure all available options are shown – even those not currently assigned to Activities in the open Project – in the Menu bar, click **Edit > User Preferences**.

In the User Preferences window, click on the Startup Filters tab and check the button to View all data for Activity Codes.

9.2. Layout to Input Activity Codes and Calendars

In the Activity view, there is a Global Layout available to Contractors to populate their schedule with Calendars, required Global Activity Codes, and optional Global Activity Codes. This layout, **CON – Baseline Development** is available by clicking **View > Layout > Open Layout**.
Under **Global Layouts**, click layout **CON – Baseline Development** and click Open.

This layout is grouped by WBS and contains the **required** columns to be populated:

- Activity ID
- Activity Name
- Global Activity Code: RESPONSIBLE PARTY (DOT GLOBAL)
- Global Activity Code: TYPE OF WORK (DOT GLOBAL)
- Calendar

Also included are the **optional, but recommended (where applicable)** columns:

- Global Activity Code: AREA (DOT GLOBAL)
- Global Activity Code: LOCATION (DOT GLOBAL)
- Global Activity Code: PHASE (DOT GLOBAL)
- Global Activity Code: STAGE (DOT GLOBAL)
9.3. Populate Many Activities at Once – Fill Down Shortcut

The above section shows a suggested layout for populating activities with Activity Codes and Calendars. To populate many activities at once with the same Activity Code or the same Calendar, there is a shortcut that can save time – the Fill Down feature in P6. In the Activity view, Fill Down allows the user to copy the Activity Code, Calendar, Original Duration, or any other editable field down to the activities immediately below. When used on many activities at once, it is much quicker than changing the editable field for each activity, one-by-one.

CAUTION: The Fill Down feature can change the values of many activities at once. Be attentive to ensure the right activities are selected, as well as the correct column is selected. Immediately following a Fill Down, the user should check to ensure the proper results were achieved. The user has the ability to undo the Fill Down by clicking the Menu bar: Edit > Undo Filldown.

In the example below, a group of Top Course Paving activities will be assigned the same Activity Code using the Fill Down feature.

- **Step 1** – Organize the schedule so that the multiple activities that you want to change at once are immediately following each other. In this instance, all grouping was removed and activities were sorted by Activity Name. “Pave Top Course” activities are in succession.

```
<table>
<thead>
<tr>
<th>Activity ID</th>
<th>Activity Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>18-10080</td>
<td>Pave Top Course - Lafayette St. Recon. - Phase 3</td>
</tr>
<tr>
<td>15-30020</td>
<td>Pave Top Course - Mill and Overlay (L.S.C.R) - Phase 3</td>
</tr>
<tr>
<td>13-10110</td>
<td>Pave Top Course - Noaxes &amp; Oswego Intersections - Pre-Phase 1</td>
</tr>
<tr>
<td>16-10160</td>
<td>Pave Top Course - Ramp G (OnRamp to SE) - Phase 1</td>
</tr>
<tr>
<td>19-10150</td>
<td>Pave Top Course - Stage 1 - Spring / Cooper Multi-Use Trail Neck</td>
</tr>
</tbody>
</table>
```

- **Step 2** – For the group of activities that will have the field values changed, change the value of the field for the top activity in the list. In this instance, the Global Activity Code TYPE OF WORK (DOT GLOBAL) for all “Pave Top Course” activities will be changed to 402 – HOT MIX ASPHALT (HMA) PAVEMENTS. The top activity in this list, activity (18-10080) has the TYPE OF WORK code changed to 402.

```
<table>
<thead>
<tr>
<th>Activity ID</th>
<th>Activity Name</th>
<th>TYPE OF WORK</th>
</tr>
</thead>
<tbody>
<tr>
<td>18-10080</td>
<td>Pave Top Course - Lafayette St. Recon. - Phase 3</td>
<td>402</td>
</tr>
<tr>
<td>15-30020</td>
<td>Pave Top Course - Mill and Overlay (L.S.C.R) - Phase 3</td>
<td>402</td>
</tr>
<tr>
<td>13-10110</td>
<td>Pave Top Course</td>
<td>402</td>
</tr>
<tr>
<td>16-10160</td>
<td>Pave Top Course - Ramp G (OnRamp to SE) - Phase 1</td>
<td>402</td>
</tr>
<tr>
<td>19-10150</td>
<td>Pave Top Course - Stage 1 - Spring / Cooper Multi-Use Trail Neck</td>
<td>402</td>
</tr>
</tbody>
</table>

```

- **Step 3** – Hold down the Shift key and single left-click on the last successive activity you want changed to this top value, being sure to click on the correct column you want.
Best Practices for CPM Schedule Specification Compliance

changed (see CAUTION above). In this instance, five “Pave Top Course” activities are selected by clicking on activity (19-10150).

<table>
<thead>
<tr>
<th>Activity ID</th>
<th>Activity Name</th>
<th>TYPE OF WORK</th>
</tr>
</thead>
<tbody>
<tr>
<td>18:10000</td>
<td>Pave Top Course - Lafayette St. Recon. - Phase 3</td>
<td></td>
</tr>
<tr>
<td>15-30020</td>
<td>Pave Top Course - Mill and Overlay (LS,C,R) - Phase 3</td>
<td></td>
</tr>
<tr>
<td>13:10110</td>
<td>Pave Top Course - Noyes &amp; Oswego Intersections - Pre-Phase 1</td>
<td></td>
</tr>
<tr>
<td>16-10160</td>
<td>Pave Top Course - Ramp G (On-Ramp to SB) - Phase 1</td>
<td>402</td>
</tr>
<tr>
<td>19-10150</td>
<td>Pave Top Course - Stage 1 - Spring / Cooper Multi-Use Trail Rec</td>
<td>402</td>
</tr>
</tbody>
</table>

• **Step 4** – Right-click on the last activity in the group, in the correct column, and select Fill Down. This will assign the field in the top selected activity to all highlighted activities below. In this instance, code 402 will be assigned to all five highlighted activities.

• **Step 5** – Review results of the Fill Down, and if the results are not desired, from the Menu bar, click Edit > Undo Filldown. This must be done before other edits or exiting the schedule, otherwise changes may not be reversible.
In the example, Fill Down could also be used for the same group of activities to apply the same Seasonal Asphalt Calendar to all “Pave Top Course” activities.

Fill Down can be used for populating many activities within a single WBS grouping as well. In the CON – Baseline Development layout, the schedule is grouped by WBS. If one element of the WBS is for Stage 1 activities and there are many activities within this Stage 1 WBS: populate the first activity within the WBS with the Activity Code for Stage 1, highlight the remaining activities within the Stage 1 WBS by clicking on the last activity in that WBS, and then right-click and Fill Down on the Stage Activity Code column.

10. Schedule Checks Using Excel

10.1. Spell Check

P6 does not have a Spell Check tool. To check spelling on Activity Names using Excel:

- **Step 1** – Open a new Excel worksheet.
- **Step 2** – In P6, Open Layout 00_Schedule Load by clicking View > Layout > Open Layout.

Under Global Layouts, click layout 00_Schedule Load and click Open.
Best Practices for CPM Schedule Specification Compliance

- **Step 3** – In P6, sort by Activity Name by clicking on the Activity Name column header.

![Activity Name Sorting](image1)

- **Step 4** – In P6, click on the first activity and click **Edit > Select All**.

![Select All](image2)

- **Step 5** – In P6, click **Edit > Copy**.

![Copy](image3)

- **Step 6** – In Excel, in cell A1, right-click and select **Paste**.

![Paste](image4)
Best Practices for CPM Schedule Specification Compliance

- **Step 7** – In Excel, click on Column B to highlight Column B, the Activity Name column.

- **Step 8** – In Excel, in the Menu Bar click on **Review > Spelling**.

- **Step 9** – In Excel, identify spelling errors and correct these errors in P6.

Note: Default Spell Check settings ignore all capital letters. It is strongly encouraged that Activity Names are not in all capital letters.
10.2. Duplicate Activity Names

The specification requires that all Activity Names be unique – no Activity Names can be duplicates. To check for duplicate Activity Names using Excel:

- **Steps 1-6** – Follow Steps 1-6 above for Spell Check.
- **Step 7** – In Excel, click on Row 1 to highlight the Row 1.

In the Menu Bar, select Data > Filter.

- **Step 8** – In Excel, click on Column B to highlight Column B, the Activity Name column.
• **Step 9** – In Excel, in the Menu Bar click on **Home > Conditional Formatting** >

The default is to highlight the Duplicate values with red fill. Click **OK**.

Duplicate Activity Names will then be highlighted in red.
• **Step 10** – In Excel, at the top of the Activity Name column, click the dropdown triangle > Filter by Color > select red.

Only duplicate Activity Names will be shown. These duplicate Activity Names should be corrected in P6 to make each Activity Name unique.

### 11. Time Restricted Clauses

The following are recommendations for implementing various time restricted clauses into the schedule.

#### 11.1. Contract Completion Date

All projects have a Contract Completion Date, which is set at the Project level by the CPM Scheduling Section. The Project’s “Must Finish By” date is set to the Current Contract Completion Date and serves as a “Finish On or Before” constraint on the end of the project. Should a Time Extension be approved or if the user believes the current “Must Finish By” date is incorrect, they should contact the CPM Scheduling Section.

#### 11.2. Interim Contract Milestones

If the project contains additional specific intermediate date restrictions beyond the Contract Completion Date, it is acceptable for the Contractor to add a “Finish On or Before” constraint to the specific dates in the Contract. It is recommended to add a Finish Milestone for the respective date restriction and assign the Constraint to that activity. For example, if the contract requires that Stage 1 traffic must be shifted onto the new alignment by November 15, add a Finish Milestone activity for “Stage 1 – Shift Traffic onto New Alignment” and constrain this activity to “Finish On or Before” November 15.

#### 11.3. Liquidated Damage (LD) and Incentive / Disincentive (I/D) Duration Periods

Duration-based time-restricted clauses are included on various projects such as A+B Bidding (“B-Clock” work), Design-Build, and other projects where Liquidated Damages (LD) or Incentive / Disincentives (I/D) are calculated based the duration for a specific scope of work within the contract.
Each and every individual duration restriction period shall have three activities:

<table>
<thead>
<tr>
<th>Activity Type</th>
<th>Activity Name</th>
<th>Calendar</th>
<th>Primary Constraint</th>
<th>Primary Constraint Date</th>
</tr>
</thead>
<tbody>
<tr>
<td>Start Milestone</td>
<td>“Start [LD / I/D] Period – [Name of LD / I/D Period]”</td>
<td>NYSDOT</td>
<td>None</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Milestone/Curing 365 Day / 8 Hour</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Level of Effort</td>
<td>“Duration for [LD / I/D] Period – [Name of LD / I/D Period] – [Enter number for contract duration] CCD”</td>
<td>NYSDOT</td>
<td>None</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Milestone/Curing 365 Day / 8 Hour</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Finish Milestone</td>
<td>“Complete [LD / I/D] Period – [Name of LD / I/D Period]”</td>
<td>NYSDOT</td>
<td>When duration restriction period starts: “Finish On or Before”</td>
<td>When duration restriction period starts: Date calculated from the contract LD / I/D duration</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Milestone/Curing 365 Day / 8 Hour</td>
<td>*see exception below</td>
<td>*see exception below</td>
</tr>
</tbody>
</table>

Working through schedule updates on many multiple-bridge and design-build projects, the best practice is not to constrain the start / finish / duration activities until each individual bridge is in progress. When a duration restriction period has started, the “Complete” Finish Milestone activity for that respective duration restriction period should have a constraint added to “Finish On or Before” the date that is calculated from the contract LD / I/D duration. This will effectively show the correct float values for each bridge once the clock starts ticking.

If a duration restriction period has not started, there should not be a constraint because the end date of the duration restriction period is not yet defined. Once in progress, the finish milestone should be constrained.

*The exception to the above is if the completion dates for the duration restriction period are hard contract dates where the Contractor must finish the respective duration restriction period by a specific date. In this instance, it is acceptable to constrain the Finish Milestone in the Baseline schedule, prior to the duration restriction period starting. The Primary Constraint Date will be set to the specific date in the contract.

12. Sequencing Activities

Schedule submissions – both Baseline schedule and progress updates – should show the most accurate, realistic plan of when work will be performed. Every schedule submission should most accurately show the Contactor’s current plan for completing submittals, fabrication, and construction activities.

For example, the Contractor is required to submit with the Baseline a list of submittals from the schedule. This list should be reviewed to crosscheck the Contractor’s plan for when submittals will be provided to NYSDOT for review with the schedule. It is inaccurate to show in the schedule all submittals stacked up immediately following the Contract Award date. The Contractor should use logic among various activities to sequence out a more realistic plan for when submissions will be made. If the project is for multiple years and some submittals will not be prepared for many months, the schedule should reflect this plan.

Another example is to sequence out upcoming construction activities so that the planned start of many activities are not pushed by the Data Date. While some activities may have a significant amount of float and can be performed at any time, the schedule should show the most realistic, accurate plan for when these activities will be performed.
Chapter 2. Checking the Schedule

This Chapter provides guidance and tips for checking and modifying a schedule prior to submission to adhere to the NYSDOT CPM scheduling specification standard.

1. Immediate Rejection Criteria and Tips for Correcting Deficiencies

Each Item 639 schedule specification includes a list of “Immediate Rejection” criteria – deficiencies that warrant an immediate rejection of the schedule and correction/resubmission by the Contractor prior to further review. These errors are identifiable through multiple methods and tips for correcting these errors are noted below.

<table>
<thead>
<tr>
<th>Immediate Rejection Criteria</th>
<th>Where to Identify Deficiency</th>
<th>Tips for Correcting Deficiency</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Failure of Project Scheduler to “schedule” project.</td>
<td>Schedule Log</td>
<td>Schedule (F9) project as final check prior to submission.</td>
</tr>
<tr>
<td>2. Failure to attach a copy of the complete Scheduling/Leveling Report (“Schedule Log”).</td>
<td>Email submission attachments</td>
<td>After scheduling (F9) the project prior to submission, save the text file and attach to submission.</td>
</tr>
<tr>
<td>3. Activities without predecessors or successors, with the exception of the first and last activity in the schedule.</td>
<td>Schedule Log AND Global Filter 01a</td>
<td>Add appropriate predecessor / successor to activities to all activities. Only first activity in schedule (typically Letting Date) should not have a predecessor. Only last activity in schedule (project completion) should not have a successor.</td>
</tr>
<tr>
<td>4. Any activity constraints that have not been approved in writing by the EIC, or that are not specifically allowed by this specification.</td>
<td>Schedule Log AND Global Filter 01c AND Global Layout 01</td>
<td>If constraints are not contract dates or have not been approved by EIC, remove from schedule.</td>
</tr>
<tr>
<td>5. Any activities with Actual Dates greater than the Data Date.</td>
<td>Schedule Log AND Global Filter 01b</td>
<td>Turn on time: Edit &gt; User Preferences &gt; Dates &gt; Time &gt; 12 hour. Correct Actual Dates to be less than or equal to the Data Date.</td>
</tr>
<tr>
<td>6. Any Milestone activities with invalid relationships.</td>
<td>Schedule Log AND Global Filters 02a and 02b</td>
<td>Start Milestones should only have SS successor relationships. Turn on Global Filter 02a, click on each activity, and review successor relationships to check that only “SS” Relationship Type is used. Finish Milestones should only have FF predecessor relationships. Turn on Global Filter 02b, click on each activity, and review predecessor relationships to check that only “FF” Relationship Type is used.</td>
</tr>
<tr>
<td>7. Failure to have a clearly defined Critical Path from the Data Date to the last activity in the schedule, using the Longest Path method. This would reflect logic errors in the project schedule.</td>
<td>Global Layout 02</td>
<td>Any gaps in the Critical Path from the current Data Date to project completion should be easily explained – whether it is a potential seasonal shutdown, contract constraint date, or other circumstance that is causing any gap.</td>
</tr>
<tr>
<td>8. Failure to attach the schedule Narrative and required appendices.</td>
<td>Email submission attachments</td>
<td>Attach Narrative and all required appendices to email submission. Review specification for requirements in Baseline versus monthly update.</td>
</tr>
<tr>
<td>9. Repeated failure to correct “Out-of-Sequence” activities.</td>
<td>Schedule Log</td>
<td>An activity is shown as Out-of-Sequence because the activity listed has an Actual Start and/or Actual Finish date that violates logic in the scheduling, indicating it has started and/or finished prior to one or more of its predecessor activities starting/finishing. Either logic should be corrected to reflect the revised sequence and/or Actual Start / Actual Finish dates need to be adjusted.</td>
</tr>
</tbody>
</table>
2. Reviewing the Schedule Log and Correcting Errors

2.1. Creating the Schedule Log

When the user schedules (F9) a project in P6, there is the option to create the text file Scheduling / Leveling Report ("Schedule Log") that shows settings, statistics and errors/warnings within the scheduled file. The Schedule Log can be created when scheduling by clicking Tools > Schedule. At the bottom of the Schedule window, click the button to Log to file and click the ellipses (…) to choose the destination for the text file.

2.2. Schedule Logs Must Match

As noted above, Immediate Rejection Criteria #1 is the failure to Schedule the project. Upon uploading and performing a high level review, the first step in the review is to make a read-only copy of the Contractor’s schedule in the State Work Area and Schedule the project. A Schedule Log is created from the read-only file and compared line-by-line with the Schedule Log submitted by the Contractor. These Schedule Logs must match each other; otherwise there have been changes to the schedule file created by the Contractor after the scheduler last ran the submitted Schedule Log. This could mean that Narratives and other attachments submitted by the Contractor may not match the file that is archived as the official read-only submission.

2.3. Schedule Log Errors and Tips for Correcting Errors

<table>
<thead>
<tr>
<th>Schedule Log Error</th>
<th>Description and Tips for Correcting Error</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Activities without predecessors</td>
<td>See above Immediate Rejection Criteria #3.</td>
</tr>
<tr>
<td>2. Activities without successors</td>
<td>See above Immediate Rejection Criteria #3.</td>
</tr>
<tr>
<td>4. Activities with Actual Dates &gt; Data Date</td>
<td>See above Immediate Rejection Criteria #5.</td>
</tr>
<tr>
<td>5. Milestone activities with invalid relationships</td>
<td>See above Immediate Rejection Criteria #6.</td>
</tr>
<tr>
<td>6. Finish milestone and predecessors have different calendars</td>
<td>Ignore this Error. Use of multiple calendars in the schedule where appropriate is encouraged.</td>
</tr>
</tbody>
</table>
3. Using Global Filters to Check Schedules

3.1. Description of Global Filters and How to Apply Filters

All users have access to a group of Global Filters that are set up to check elements of the schedule and how well they do or do not meet certain criteria of the CPM scheduling specification. These Filters are part of the regular high level review as part of a series of technical “checks” of each schedule submission. The Contractor has access to these Filters to check their schedule prior to submission. Finding these errors and correcting prior to submitting will result in a cleaner schedule, less NYSDOT review comments, and quicker submission turnaround time for all parties. To access these Global Filters in the system, in the Menu bar, click View > Filter By > Customize, or by clicking the funnel icon (🔍) shown below, then Customize.

In the Filters window, under Filter, scroll down to Global Filters. Under this heading, there are a group of filters starting with “01” and ending with “10” that are a series of technical checks performed on each submission. In the PIngDesign database, these filters start with an underscore ("_01" through "_10").
Best Practices for CPM Schedule Specification Compliance

To apply each Filter and perform each check:

- **Step 1** – Check the box for **All Activities**, which clears any current filters applied.
- **Step 2** – Check the **Select** box for one of the Filters.
- **Step 3** – Click **Apply** to view the results of the Filter that is applied. If there are items that need to be corrected in this Filter, click **OK** to keep the filter applied and to close the Filters window.

### 3.2. List of Global Filters and Tips for Correcting Potential Deficiencies

These Filters are set up to use key words and other criteria to filter activity data. The Filters are not 100% perfect and there are potential exceptions to each Filter. If the High Level Review has comments on activities from a Filter that the scheduler believes meet the CPM schedule specification, please contact the CPM Scheduling Section to discuss.

**Note:** These Filters are organized in a specific order and intended to be run in this order. If errors are found, correct these errors prior to moving on to the next Filter. Succeeding Filters rely on the user to correct coding and calendars from previous Filters.

<table>
<thead>
<tr>
<th>Global Filter and Description</th>
<th>Tips for Correcting Deficiency</th>
</tr>
</thead>
<tbody>
<tr>
<td>01a_Activities w/o Pred &amp; Succ Activities without predecessors or successors.</td>
<td>Add appropriate predecessor / successor to all activities. Only first activity in schedule (typically Letting Date) should not have a predecessor. Only last activity in schedule (project completion) should not have a successor.</td>
</tr>
<tr>
<td>01b_Actual Dates &gt; Data Date Activities with an Actual Start or Actual Finish date greater than the Data Date.</td>
<td>Turn on time: Edit &gt; User Preferences &gt; Dates &gt; Time &gt; 12 hour. Correct Actual Dates to be less than or equal to the Data Date.</td>
</tr>
<tr>
<td>01c_Constraints Activities with Constraints.</td>
<td>If constraints are not contract dates or have not been approved by EJC, remove from schedule.</td>
</tr>
<tr>
<td>02a_Start MS – only SS Succ Start Milestone activities.</td>
<td>Start Milestones should only have SS successor relationships. Click on each activity and review successor relationships to check that only “SS” Relationship Type is used.</td>
</tr>
<tr>
<td>02b_Finish MS – only FF Pred Finish Milestone activities.</td>
<td>Finish Milestones should only have FF predecessor relationships. Click on each activity and review predecessor relationships to check that only “FF” Relationship Type is used.</td>
</tr>
<tr>
<td>03a_(RESP PARTY) no code assigned Activities missing the RESPONSIBLE PARTY (DOT GLOBAL) Activity Code.</td>
<td>Assign the appropriate required RESPONSIBLE PARTY (DOT GLOBAL) Activity Code to each activity in this Filter.</td>
</tr>
<tr>
<td>03b_(TYPE OF WORK) no code assigned Activities missing the TYPE OF WORK (DOT GLOBAL) Activity Code.</td>
<td>Assign the appropriate required TYPE OF WORK (DOT GLOBAL) Activity Code to each activity in this Filter.</td>
</tr>
<tr>
<td>04a_Inapprop Global Calendar Activities assigned to any Global Calendar that is not one of the two allowable Global Calendars.</td>
<td>Change the calendar for these activities to the appropriate calendar – either a Project Calendar or one of the two allowable Global Calendars.</td>
</tr>
<tr>
<td>04b_MS not on Global MS/Curing cal Start or Finish Milestones not assigned to the Global Calendar “NYSDOT Milestone/Curing 365 Day / 8 Hour”.</td>
<td>Change the calendar for these activities to the Global Calendar “NYSDOT Milestone/Curing 365 Day / 8 Hour”. In rare instances where Milestones should be occurring out the traditional 8-hour calendar and this affects the schedule, Milestones could be allowed to be on a different calendar.</td>
</tr>
<tr>
<td>04c_Cure NOT on Global MS/Curing cal Potential concrete curing activities not assigned to the Global Calendar “NYSDOT Milestone/Curing 365 Day / 8 Hour”.</td>
<td>Review activities and determine if any are concrete curing activities that should have the calendar changed to the Global Calendar “NYSDOT Milestone/Curing 365 Day / 8 Hour”.</td>
</tr>
</tbody>
</table>
### Global Filter and Description

<table>
<thead>
<tr>
<th>Description</th>
<th>Tips for Correcting Deficiency</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>04d_Rev/Apprv not on State cal</strong></td>
<td>Review activities and determine if any of these are NYSDOT-responsible review and approve activities that should have the calendar changed to the Global Calendar “State Business Days, 5 Day Work Week w/ State Holidays, Field”.</td>
</tr>
<tr>
<td><strong>04e_RESP = DOT &amp; cal &lt;&gt; Global State</strong></td>
<td>Activities coded to NYSDOT-responsibility should have the calendar changed to the Global Calendar “State Business Days, 5 Day Work Week w/ State Holidays, Field”. Correct RESPONSIBLE PARTY (DOT GLOBAL) Activity Code if necessary.</td>
</tr>
<tr>
<td><strong>04f_Cal = Global State &amp; inapprop</strong></td>
<td>Review activities and if they should not be on the Global Calendar “State Business Days, 5 Day Work Week w/ State Holidays, Field”, reassigned to a different appropriate calendar.</td>
</tr>
<tr>
<td><strong>04g_RESP = CON &amp; inapprop Global cal</strong></td>
<td>Activities coded to Contractor-responsibility – except for milestones and concrete curing – should generally be assigned to a Project Calendar. Reassigned to Project Calendar if necessary. Correct RESPONSIBLE PARTY (DOT GLOBAL) Activity Code if necessary.</td>
</tr>
<tr>
<td><strong>04h_Cal = Global MS &amp; inapprop</strong></td>
<td>Review activities and determine if any should not be on the Global 365-day calendar, but should be reassigned to a different calendar.</td>
</tr>
<tr>
<td><strong>04i_Project cal &amp; RESP &lt;&gt; CON</strong></td>
<td>Review activities and determine if any of these activities on Project Calendars should either be coded to Contractor-responsibility or the calendar should be changed to one of the two allowable Global Calendars.</td>
</tr>
<tr>
<td><strong>05a_Asphalt on seasonal calendar?</strong></td>
<td>Sort activities by Activity Name and add column for Calendar. Review activities and confirm that asphalt activities are assigned to an appropriate seasonally-restricted Project Calendar.</td>
</tr>
<tr>
<td><strong>05b_Concrete on seasonal calendar?</strong></td>
<td>Sort activities by Activity Name and add column for Calendar. Review activities and confirm that any seasonally-restricted concrete activities are assigned to an appropriate seasonally-restricted Project Calendar.</td>
</tr>
<tr>
<td><strong>05c_Winter/Shutdown activities – inapprop</strong></td>
<td>Winter shutdown activities are not allowed but rather winter shutdown periods should be represented by seasonally-restricted calendars.</td>
</tr>
<tr>
<td><strong>05d_Construction not started &amp; RD &gt;15d</strong></td>
<td>Submittals, fabrication and inspection activities excluded; not-started construction activity durations shall not exceed 15 days unless approved by the EIC. Review activities and break down activities into further detail, or request variance by EIC.</td>
</tr>
<tr>
<td><strong>06_Expected Finishes</strong></td>
<td>Expected Finish dates should not be used unless authorized by the EIC in rare circumstances. Remove Expected Finish dates where not authorized.</td>
</tr>
<tr>
<td><strong>07a_Not Started Orig/Rem Dur = 0d</strong></td>
<td>Adjust the Original Duration and/or Remaining Duration for these Task Dependent activities to be greater than 0 days.</td>
</tr>
<tr>
<td><strong>07b_In Progress &amp; Rem Dur = 0d</strong></td>
<td>Adjust the Remaining Duration to the appropriate remaining number of days, or mark the activity as complete, if applicable.</td>
</tr>
<tr>
<td><strong>07c_In Progress &amp; RD = OD</strong></td>
<td>Activities that have started but have not made any progress on the Original Duration. Either reduced the Remaining Duration to show that progress has been made, or acknowledge that the Original Duration was too small and will be exceeded.</td>
</tr>
</tbody>
</table>
## 4. Multiple Float Paths

P6 has a optional feature to “calculate multiple float paths” – a way of showing the most critical path of activities towards achieving a specified completion activity as well as grouping of sub-critical paths, from most critical to least critical. The target activity can be changed to any activity in the schedule. The target activity can be the last activity in the schedule, to show the varying levels of critical paths and sub-critical paths to completing the project; or it can be a specified intermediate activity to show the varying levels of critical work to completing that specified intermediate activity. The latter is very useful in determining the critical and near-critical paths to achieving intermediate milestones (contractual or not contractual) or possibly completing individual bridges in schedules where there are multiple bridges that are not logically tied together.

### 4.1. How to Calculate Multiple Float Paths

Below are the steps to calculating multiple float paths:

- **Step 1** – Identify the target activity, as described above.
- **Step 2** – In the Menu bar, click **Tools > Schedule**.

<table>
<thead>
<tr>
<th>Global Filter and Description</th>
<th>Tips for Correcting Deficiency</th>
</tr>
</thead>
</table>
| **07d_Complete & Actual Dur = 0d**  
  Complete non-milestone activities with an Actual Duration equal to 0d. | Task Dependent activities shall not have a 0d duration, including Actual Durations. Turn on time: Edit > User Preferences > Dates > Time > 12 hour. Correct Actual Start and Actual Finish dates so that 1) they are not at the same time, and 2) they are not during non-working times on the currently assigned calendar. If work was performed on a non-working time or non-work day, the activity should be reassigned to a calendar that has the Actual Start and Actual Finish times as work days. Avoid Actual Duration = 0d by turning time on prior to entering Actual Start and Actual Finish dates. |
| **08a_Activities pushed by Data Date**  
  Activities that have not started and are planned to start within 4d of the Data Date. | Sort activities by Start date and review predecessors for each activity. If the activities predecessors have been completed earlier than the Data Date and these activities will not start on the Data Date, add appropriate logic to produce an accurate and realistic plan for when the activity will be performed. |
| **08b_In Progress & At Comp Dur > 15d**  
  In-progress Task Dependent activities with a scheduled At Completion Duration greater than 15d. | Due to the 15-day specification limit on construction activities, any in-progress construction activities with scheduled At Completion Durations greater than 15 days are most likely dragging on in the schedule. If legitimate, potentially comment in Narrative as to why these activities are taking longer than planned. If these activities should be marked as complete, do so. |
| **09_Negative Total Float**  
  Activities with negative float. | Negative float is not allowed in the Baseline schedule and these activities and/or schedule logic needs adjustment to eliminate negative float. |
| **10_No Prod Rate & TF < 20d**  
  Task dependent activities missing Production Rate data. | Some projects require the Contractor to populate schedules with Production Rate information for activities with 20d or less of Total Float. The User Defined Fields to be populated can be added columns for “PR Quantity”, “PR Unit”, and “Production Rate/Day”. |
Best Practices for CPM Schedule Specification Compliance

- **Step 3** – In the Schedule window, click **Options** to open the Schedule Options window. Click on the **Advanced** tab to access the multiple float path options.

- **Step 4** – Check the box for **Calculate Multiple Float Paths**. Click the button for “Calculate multiple paths using” **Free Float**. Next to “Display multiple float paths ending with activity”, click the ellipses (…) to open the Select Activity window. Type in the **Activity Name** for the target activity selected in Step 1. Click the green (+) icon to select and exit.
Best Practices for CPM Schedule Specification Compliance

- **Step 5** – In the **Schedule Options** window, increase the “Specify the number of paths to calculate” to **200** by typing it in. Click **Close**.

![Schedule Options Window](image)

- **Step 6** – In the **Schedule** window, click **Schedule**.

4.2. Layout for Reviewing Multiple Float Paths

In the Activity view, there is a Global Layout available to view multiple float paths. This layout, **22 – Multiple Float Paths** is available by clicking **View > Layout > Open Layout**.

![View > Layout](image)

Under **Global Layouts**, click layout **22_Multiple Float Paths** and click **Open**.

![Open Layout](image)

The most critical float path to completing the target activity is at the top, followed by sub-critical float paths, by decreasing levels of criticality. This layout filters for only remaining activities, and filters out Level of Effort activities.
5. Opening ‘Schedule Report’ Global Layouts

With every High Level Review performed, the PMO attaches a “Schedule Report” PDF file that contains layouts to help assist NYSDOT project staff review each schedule submission. This report contains layouts for critical path, 30-day look-aheads, slipping activities, scheduled winter work, and other various layouts. These numbered layouts are Global Layout available to the Contractor to review their schedule submission as well. Go to the Activity view and then click View > Layout > Open Layout.

Many of these layouts make reference to the previous schedule update in order to track any variance in dates or durations from the previous update. In order to make this comparison, the schedule file needs a copy of the previous update inserted into the current file and set as a Baseline to the current file. This is performed with every read-only schedule upload in the State’s work area, but is not done regularly in the Contractor’s work area. For security reasons, to avoid Contractor’s accidentally deleting archived read-only schedule submissions in the State’s work area, the Baseline assignment must be performed by the CPM Scheduling Section upon Contractor’s request. The request can be made at any time to the CPM Scheduling Section by sending an email request to CPMSchedulingSection@dot.ny.gov, identifying which Project ID will be the current project and which Project ID is requested to be the previous update for comparison. Nomenclature can be:

“Please assign previous update [enter name of previous update Project ID] as a Baseline to current schedule [enter name of current schedule Project ID]. For example, “Please assign previous update D269997-1SU06 as a Baseline to current schedule D269997-1SU07.”
6. **Notebook Utilization**

6.1. **Making Notes on Activities**

The Notebook feature in P6 allows the Contractor to add notes to any activity in the schedule. This is useful in tracking activity-specific information in the schedule such as:

- Delays
- Suspensions of work
- Changes in Lags / Changes in Logic / Changes in Calendars

To add a Notebook topic to an activity:

- **Step 1** – Click on the specific activity and in the Activity Detail view, click on the tab **Notebook**. Under **Notebook Topic**, click **Add**.

- **Step 2** – The **Assign Notebook Topic** window will open and there are a variety of available Notebook Topics. It is recommended to use the Notebook Topics for “**Progress Submission xx Revisions**”, to accurately link when the notes were added in relation to the monthly update number. Press the green (+) icon to add a Notebook Topic. Close out of the window.
Best Practices for CPM Schedule Specification Compliance

• **Step 3** – Click the **Modify** button and a window will pop up to add text. Add comments, with specific dates and other applicable details. Click **OK** to close.

6.2. Printing Notebook Topic Report

Adding Notebook Topics to activities allows the scheduler to print a report showing the details of the Notebook Topics. This is very useful for developing the monthly Narrative and documenting any specific issues beyond the standard scope of the Activity Name.

• **Step 1** – In the Menu bar, click **Tools > Reports > Reports**.

• **Step 2** – Find the report titled **Activity Notebook**. Right-click on this report and click **Run > Report**.
Best Practices for CPM Schedule Specification Compliance

- **Step 3** – The Run Report window opens and we recommend doing a Print Preview. Click OK.

![Run Report window]

- **Step 4** – In the Print Preview, this will show the activity, notebook topic title, and details. Print to PDF and use for the Narrative.

![Activity Notebook]

<table>
<thead>
<tr>
<th>Project</th>
<th>Activity</th>
</tr>
</thead>
<tbody>
<tr>
<td>D209997 Contractor Scheduler Training</td>
<td>C0025 Install Piles - E Abut - S1 Rt. 66</td>
</tr>
<tr>
<td>Progress Submission</td>
<td>4/15/2016: Work started today. 3 north piles installed. Hit rock at pile 66E4 and could not drive any further piles.</td>
</tr>
<tr>
<td>Revisions</td>
<td></td>
</tr>
</tbody>
</table>
Chapter 3. Submitting the Schedule

This Chapter discusses the logistics of making a schedule submission and provides guidance and tips for creating a submission that meets the NYSDOT CPM scheduling specification standard.

1. Submission Work Flow

As discussed at the beginning of Chapter 1, Attachment 1 is a work flow that details and separates the steps of the Item 639 CPM scheduling process in sequential order. The work flow diagrams the process for the Contractor, CPM Scheduling Section, EIC, ACS and the optional Detailed Reviewers, from Letting Date through Contract Completion and the As-Built Schedule. It is strongly recommended that this process be reviewed to understand which party has responsibilities during each phase of the CPM schedule.

2. Schedule Submission Due Dates

Schedule submission due dates are in each Item 639 specification. Below is a table summarizing the required timeframes for each different type of schedule submission, common for most contracts. Always refer to the specifications for official policy.

<table>
<thead>
<tr>
<th>Schedule Submission Type</th>
<th>Due Date</th>
</tr>
</thead>
<tbody>
<tr>
<td>Draft Baseline Progress Schedule (optional)</td>
<td>Optional submission is strongly encouraged. May be made anytime following notice to the Contractor that they are the apparent low bidder on the contract.</td>
</tr>
<tr>
<td>Baseline Progress Schedule @ Award</td>
<td>Due within 10 Work Days of receipt of the Contract Award. No work other than installation of the Engineer’s Field Office, mobilization, procurement and administrative activities, installation of construction signs, installation of erosion and pollution protection, clearing and grubbing, field measurements, and survey and stakeout will be permitted to start until the Baseline Progress Schedule @ Award has been submitted to the Engineer.</td>
</tr>
<tr>
<td>Final Baseline Progress Schedule @ Award</td>
<td>Acceptance by Engineer shall not exceed 40 Work Days from receipt of the Contract Award.</td>
</tr>
<tr>
<td>First Progress Schedule Submission</td>
<td>Due within 3 Work Days following acceptance of the Final Baseline Progress Schedule @ Award.</td>
</tr>
<tr>
<td>Look-Ahead Schedule</td>
<td>Due on a weekly basis.</td>
</tr>
<tr>
<td>Subsequent Progress Schedule Submissions</td>
<td>Due within 3 Work Days of the last day of the month (or any other repeating Data Date agreed upon by the Engineer).</td>
</tr>
<tr>
<td>As-Built Progress Schedule</td>
<td>Due within 10 Work Days following Contractor’s Last Day of Work.</td>
</tr>
</tbody>
</table>
3. File Naming Conventions

Schedule submission file naming conventions are in each Item 639 specification. Below is an example of file naming conventions for each different type of schedule submission, common for most contracts.

<table>
<thead>
<tr>
<th>Progress Schedules</th>
<th>1st Version</th>
<th>2nd Version</th>
<th>3rd Version</th>
</tr>
</thead>
<tbody>
<tr>
<td>Draft Baseline Progress Schedule</td>
<td>D26####-1DB</td>
<td>D26####-2DB</td>
<td>D26####-3DB</td>
</tr>
<tr>
<td>Baseline Progress Schedule @ Award</td>
<td>D26####-1BPS</td>
<td>D26####-2BPS</td>
<td>D26####-3BPS</td>
</tr>
<tr>
<td>Final Baseline Progress Schedule @ Award</td>
<td>D26####-1FB</td>
<td>D26####-2FB</td>
<td>D26####-3FB</td>
</tr>
<tr>
<td>Monthly Progress Schedule Submission #1</td>
<td>D26####-1SU01</td>
<td>D26####-2SU01</td>
<td>D26####-3SU01</td>
</tr>
<tr>
<td>Monthly Progress Schedule Submission #2</td>
<td>D26####-1SU02</td>
<td>D26####-2SU02</td>
<td>D26####-3SU02</td>
</tr>
<tr>
<td>Monthly Progress Schedule Submission #3</td>
<td>D26####-1SU03</td>
<td>D26####-2SU03</td>
<td>D26####-3SU03</td>
</tr>
<tr>
<td>Monthly Progress Schedule Submission #4</td>
<td>D26####-1SU04</td>
<td>D26####-2SU04</td>
<td>D26####-3SU04</td>
</tr>
<tr>
<td>As-Built Progress Schedule (Last Progress Schedule)</td>
<td>D26####-1AB</td>
<td>D26####-2AB</td>
<td>D26####-3AB</td>
</tr>
<tr>
<td>1st Time Impact Analysis</td>
<td>D26####-1TIA1</td>
<td>D26####-2TIA1</td>
<td>D26####-3TIA1</td>
</tr>
<tr>
<td>1st Recovery Schedule</td>
<td>D26####-1RS1</td>
<td>D26####-2RS1</td>
<td>D26####-3RS1</td>
</tr>
</tbody>
</table>

4. Narrative

Narrative requirements are detailed in each Item 639 specification and are split between Narrative requirements for Baseline submissions and Narrative requirements for monthly progress schedule submissions. Both the Baseline and monthly update Narrative requirements fully detail the expectations for the Contractor’s Narrative. It is strongly encouraged that the Narrative’s sections match the headings outlined in the specification. These requirements should be thoroughly reviewed and adhered to, as the specification outlines the required level of detail and information for each section. Below are comments regarding the required Appendices.

- **Appendix 1 – Scheduling / Leveling Report** – Helpful to CPM Scheduling Section if this is submitted in the native format, a Text file. Do not delete any sections from the report.
- **Appendix 2 – Progress Schedule Plot** – Encouraged to use Global Layout “CON_Appendix 2 Long Path” (“_CON” with an underscore in the PlngDesign database).
- **Appendix 3 – Full Schedule** – Encouraged to use Global Layout “CON_Appendix 3 Full Sched” (“_CON” with an underscore in the PlngDesign database).
- **Appendix 4 – Notebook Topics** – Encouraged to use the Report discussed in the previous Notebook Utilization section.

5. Exporting / Copying / Saving

The following sections offer guidance for exporting, copying, and saving from the Citrix-based system. Chapter 1 explains how to log into Citrix.

5.1. T-drive

When exporting files, printing to PDF, or saving other files from the Citrix system, the user should choose the “T” (“temporary”) drive as the location. The T-drive is on the Citrix server and allows for much quicker writing speeds than if the user tries writing directly to their personal computer’s C-drive. When writing files to the T-drive, it is strongly recommended to include the contract D# so files can be easily located.
5.2. File Transfer of PDF Files

Within P6, the user has access to printing to PDF files. When asked to Save As, click the Save in dropdown to change to the T-drive. Save the file.

Within Citrix, the user will have access to Primavera P6, and also have access to a file transfer utility.

This application allows the user to quickly copy files from the Citrix’s T-drive onto their personal computer’s C-drive. Open the File Transfer application, locate the file in the T-drive folder location, and copy/paste WITHIN THE FILE TRANSFER WINDOW to the personal computer’s C-drive.
5.3. Exporting Schedule File

If the user wants a copy of the schedule file outside of the Citrix P6 system, they have the ability to export any P6 file in various formats from the system. To export, in the Menu bar, click File > Export. As noted above, save the file with the D# to the T-drive and then transfer onto the personal computer’s C-drive.

Note: CPM Scheduling Section cannot import project schedule files.

5.4. Schedule Log

The previous section on Schedule Logs discussed how to create the file. Again, the same as PDF and schedule file exports, the user should save the Schedule Log Text file to the T-drive and transfer to the C-drive using the File Transfer application.

5.5. Claim Digger

Claim Digger is a program within Primavera P6 that allows the user to compare the current open schedule file to any other file that the user has access to in the system. This is helpful when performing schedule updates to identify all changes that have been made, and to ensure that changes are documented properly in the Narrative. While the user should attach the Claim Digger report to the schedule submission, Narrative must detail the changes and why they occurred. Stating that “activities were deleted” or “Original Durations were changed” does not suffice in the Narrative; rather changes must be detailed as required by the schedule specification.
To access Claim Digger, in the Menu bar, click **Tools > Claim Digger**.

In the **Claim Digger** window, the **Select Revised Project** is by default, the current open project. The **Select original project or baseline** is the project the user wishes to compare the current open project. Select the project for comparison, identify the **Output File** location, and click **Compare**.

There are many options within Claim Digger than can make the report very long and unreadable. Below are preferred settings to limit the size of the report to fields that are useful in creating the monthly Narrative. These options can be accessed by clicking **Advanced** to bring up the **Advanced Project Comparison Options** window.
The **General Activity Data** portion of the Claim Digger report is long, but useful sections within the General Activity Data include:

- Changes to the activities on the Critical Path
- Changes to activity calendar assignments
- Changes to Original Duration, which must be noted in the Narrative

Note: Claim Digger durations are in hours, so a duration or float value listed at 8.0 is most likely 1 day.

### 6. Email Submission Protocol

As outlined in the specification, each schedule submission should be sent to the Engineer via email. Below is a list of others who should be included on the submission.

- **To:**
  - Engineer
- **CC:**
  - CPM Scheduling Section ([CPMSchedulingSection@dot.ny.gov](mailto:CPMSchedulingSection@dot.ny.gov))
  - Area Construction Supervisor
  - Regional CPM Coordinator
  - Detailed Reviewer (if applicable)
  - Contractor (if schedule is being submitted by a schedule consultant)
  - Any other NYSDOT staff included on previous emails

Including the D# in all email correspondence is important, because it is used to quickly locate emails when providing Contractors and NYSDOT Regional staff schedule assistance. Email subject requirements in the specification can be reduced to only include the following.

- D#, Update #, Region #, and “Schedule”
- For example, “D269997-1SU06 – Region 1 – Schedule”
Email message should include:

- Intentions of the email, such as “Please upload to the State’s work area for review.”
- EIC
- ACS
- Current anticipated completion date of the schedule, and how it compares to the current contract completion date.

7. Schedule Submission Checklist

Attachment 2 – NYSDOT Schedule Submission Checklist is a checklist for Contractors to use as guidance for checking technical aspects of the schedule prior to schedule submission. This checklist should be used prior to each schedule submission and lists many of the requirements of the CPM scheduling specification, as well as other best practices.

Chapter 4. Attachments

Attachment 1 – NYSDOT Schedule Work Flow
Attachment 2 – NYSDOT Schedule Submission Checklist
Attachment 1 - NYSDOT Schedule Work Flow
Within 10 Work Days after Contractor's Last Day of Work
Contractor Prepares & Submits As-Built Schedule (AB)
  PMO Uploads and Performs High Level Review
  EIC Reviews
  ACS / Detailed Reviewer Reviews (optional)
EIC Accepts / Rejects and Sends Comments to Contractor (CC: PMO)
Accept
Reject
Item 639 CPM Schedule Complete

Contractor Prepares & Submits Monthly Schedule Update (SU)
PMO Uploads and Performs High-Level Review
EIC Reviews
ACS / Detailed Reviewer Reviews (optional)
EIC Accepts / Rejects and Sends Comments to Contractor (CC: PMO)
Accept
Reject
Contractor's Last Day of Work Complete?
No
Yes

Contract Award + 40 Work Days (maximum)
Within 3 Work Days after Final Baseline Acceptance or Monthly Data Date
Monthly Updates
As-Built Schedule

NYSDOT Schedule Work Flow – 2 of 2
Attachment 2 – NYSDOT Schedule Submission Checklist
# NYSDOT Schedule Submission Checklist

## Submission Preparation

- [ ] Submission made within proper timeframe
- [ ] Project ID matches spec naming convention
- [ ] Previous NYSDOT comments addressed
- [ ] All progress has been accounted for
- [ ] All planned work is accounted for
- [ ] Look-ahead and remaining schedules accurately represent the current realistic plan for completing work

## Global Filters

- [ ] 01a_Activities w/o Pred & Succ
- [ ] 01b_Actual Dates > Data Date
- [ ] 01c_Constraints
- [ ] 02a_Start MS – only SS Succ
- [ ] 02b_Finish MS – only FF Pred
- [ ] 03a_(RESP PARTY) no code assigned
- [ ] 03b_(TYPE OF WORK) no code assigned
- [ ] 04a_Inapprop Global Calendar
- [ ] 04b_MS not on Global MS/Curing cal
- [ ] 04c_Cure NOT on Global MS/Curing cal
- [ ] 04d_Rev/Apprv not on State cal
- [ ] 04e_RESP = DOT & cal <> Global State
- [ ] 04f_Cal = Global MS & inapprop
- [ ] 04g_RESP = CON & inapprop Global cal
- [ ] 04h_Cal = Global MS & Pred
- [ ] 05a_Asphalt on seasonal calendar?
- [ ] 05b_Concrete on seasonal calendar?
- [ ] 05c_Winter/Shutdown activities – inapp
- [ ] 05d_Construction not started & RD >15d
- [ ] 06_Expected Finishes
- [ ] 07a_Not Started Orig/Rem Dur = 0d
- [ ] 07b_In Progress & Rem Dur = 0d
- [ ] 07c_In Progress & RD = OD
- [ ] 07d_Complete & Actual Dur = 0d
- [ ] 08a_Activities pushed by Data Date
- [ ] 08b_In Progress & At Comp Dur > 15d
- [ ] 08c_In Progress & RD = OD
- [ ] 08d_Complete & Actual Dur = 0d
- [ ] 09_Negative Total Float

## Other Checks

- [ ] WBS nodes are unique and have proper detail
- [ ] Activity Names are unique and no duplicates
- [ ] Activity Names contain verb, object & location
- [ ] Activity Names are consistent in nomenclature
- [ ] Activity Names were spell checked
- [ ] Activity Codes used by project assigned to all activities
- [ ] Intermediate contractual dates have proper constraints
- [ ] Project Calendar names contain DF & proper description
- [ ] Project Calendars created and assigned for seasonally restricted activities
- [ ] Project Calendars have proper working days, times and “Time Periods”
- [ ] Project Calendars other than 5d/8h have dispensation approved
- [ ] Project Calendars do not include weather days
- [ ] Future season work driven by calendars, not constraints
- [ ] Activity Codes used by project assigned to all activities
- [ ] Intermediate contractual dates have proper constraints
- [ ] Project Calendar names contain DF & proper description
- [ ] Project Calendars created and assigned for seasonally restricted activities
- [ ] Project Calendars have proper working days, times and “Time Periods”
- [ ] Project Calendars other than 5d/8h have dispensation approved
- [ ] Narrative includes all required sections from specification, including detail required for each section

## Immediate Rejection

- [ ] Failure of Project Scheduler to “schedule” project.
- [ ] Failure to attach a copy of the complete Scheduling/Leveling Report (“Schedule Log”).
- [ ] Activities without predecessors or successors, with the exception of the first and last activity in the schedule.
- [ ] Any activity constraints that have not been approved in writing by the EIC, or that are not specifically allowed by this specification.
- [ ] Any activities with Actual Dates greater than the Data Date.
- [ ] Any Milestone Activities with invalid relationships.
- [ ] Failure to have a clearly defined Critical Path from the Data Date to the last activity in the schedule, using the Longest Path method. This would reflect logic errors in the project schedule.
- [ ] Failure to attach the schedule Narrative and required appendices (see below).
- [ ] Repeated failure to correct “Out-of-Sequence” activities.

## Submission Requirements

- [ ] Email – To: EIC, CC: CPM, ACS, Regional CPM Coord., Detailed Reviewer, Contractor, Other NYSDOT
- [ ] Email Subject – D#, Update #, Region #, “Schedule”
- [ ] Email Body – “Please Upload…”, EIC, ACS, Current completion date compared to current contract date
- [ ] Narrative
- [ ] Claim Digger report (optional, but encouraged)

### Appendix

- [ ] Appendix 1 – Schedule Log
- [ ] Appendix 2 – Progress Schedule Plot with Longest Path (Global Layout “CON_Appendix 2 Long Path”)
- [ ] Appendix 3 – Full Schedule (Global Layout “CON_Appendix 3 Full Sched”)
- [ ] Appendix 4 – Notebook Topics